Skip to main content
Skip table of contents

Preinstalled Packages


When writing scripts, it is generally recommended to use the packages that have been preinstalled with Seeq Data Lab rather than installing a pinned version locally. Here are the packages that come standard with Seeq Data Lab for both the Python and R kernels.


Version : 3.8.16

Below is a subset of packages that are most used. For a complete set of the locally installed packages, execute the following commands in a Data Lab terminal.

Locally Installed Packages

pip list

Globally installed packages

PYTHONUSERBASE=/seeq/python/global-packages pip list

Pre-installed packages

PYTHONUSERBASE=/usr/local pip list

In an effort to maintain modern and supportable preinstalled packages, along with eliminating longer install times associated with some packages, in recent versions of Seeq we have both updated package versions and also added additional preinstalled packages.

Where possible, it's advantageous to use the preinstalled packages instead of reinstalling them locally. You can ensure the preinstalled packages will be used by either not specifying a required version, or by specifying a minimum version that is less than or equal to the version that is preinstalled (e.g. numpy>=1.22.0) in your requirements.txt file.

Subset of Preinstalled Packages:

R58.6.1+, R59.2.2+, R60.1.5+, R61.0.1+, R62.0.0+

We have updated the following preinstalled package version numbers:

Bottleneck = "1.3.7"
ipyvuetify = "1.8.5"
Markdown = "3.4.3"
numpy = "1.23.5"
pandas = "1.5.3"
plotly = "5.14.1"
scipy = "1.8.1"
SQLAlchemy = "2.0.7"

And we have added the following preinstalled packages:

bokeh = "2.4.3"
Django = "4.1.7"
image = "1.5.33"
ipycytoscape = "1.3.3"
isotree = "0.2.7.post1"
kaleido = "0.2.1"
memoization = "0.3.2"
scikit-learn = "1.2.2"
statsmodels = "0.13.5"
twine = "3.4.1"

R58.6.0, R59.2.1, R60.1.4, R61.0.0

beautifulsoup4 = "4.9.3"
ipyvuetify = "1.8.2"
ipywidgets = "7.7.0"
jupyterlab = "3.4.8"
Mako = "1.1.4"
Markdown = "3.4.1"
matplotlib = "3.5.1"
numpy = "1.22.0"
pandas = "1.3.5"
plotly = "5.5.0"
psutil = "5.9.0"
qgrid = "1.3.1"
recurrent = "0.4.0"
requests = "2.26.0"
scipy = "1.7.3"
SQLAlchemy = "1.4.29"



JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.